re = /<([A-z0-9-_]+)(([^>"]+"[^"]*")*\s*)\/>/m
str = ' <div class="bbn-flex-fill">
<div v-if="arrowsPosition.startsWith(\'top\')"
class="bbn-flex bbn-bottom-sspace"
:style="arrowsStyle">
<i v-show="showArrowLeft"
:class="[leftArrowClass, \'bbn-p\', \'bbn-lg\']"
@click="prev"
:style="{visibility: (currentIndex === 0 && !loop)? \'hidden\' : \'visible\'}"/>
<i v-show="showArrowRight"
@click="next"
:class="[
rightArrowClass,
\'bbn-p\',
\'bbn-lg\'
]"
:style="{visibility: (currentIndex >= items.length - 1) && !loop ? \'hidden\' : \'visible\'}"/>
</div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end