using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([A-z0-9-_]+)(([^>""]+""[^""]*"")*\s*)/>";
string input = @" <div class=""bbn-flex-fill"">
<div v-if=""arrowsPosition.startsWith('top')""
class=""bbn-flex bbn-bottom-sspace""
:style=""arrowsStyle"">
<i v-show=""showArrowLeft""
:class=""[leftArrowClass, 'bbn-p', 'bbn-lg']""
@click=""prev""
:style=""{visibility: (currentIndex === 0 && !loop)? 'hidden' : 'visible'}""/>
<i v-show=""showArrowRight""
@click=""next""
:class=""[
rightArrowClass,
'bbn-p',
'bbn-lg'
]""
:style=""{visibility: (currentIndex >= items.length - 1) && !loop ? 'hidden' : 'visible'}""/>
</div>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}