// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<([A-z0-9-_]+)(([^>"]+"[^"]*")*\s*)/>"#).unwrap();
let string = " <div class=\"bbn-flex-fill\">
<div v-if=\"arrowsPosition.startsWith('top')\"
class=\"bbn-flex bbn-bottom-sspace\"
:style=\"arrowsStyle\">
<i v-show=\"showArrowLeft\"
:class=\"[leftArrowClass, 'bbn-p', 'bbn-lg']\"
@click=\"prev\"
:style=\"{visibility: (currentIndex === 0 && !loop)? 'hidden' : 'visible'}\"/>
<i v-show=\"showArrowRight\"
@click=\"next\"
:class=\"[
rightArrowClass,
'bbn-p',
'bbn-lg'
]\"
:style=\"{visibility: (currentIndex >= items.length - 1) && !loop ? 'hidden' : 'visible'}\"/>
</div>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}