#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^t]|t(?!his sequence))+$"
Local $sString = "ahkg'ash fhsdh" & @CRLF & _
" dfh sdh dfh sdh dhfd hdf hdfh dtfh fdh" & @CRLF & _
"this sequence dg" & @CRLF & _
"gdsdfgdfgdfgdsfgdf" & @CRLF & _
"asd this sequence dg" & @CRLF & _
"gdsdfgdfgdfgdsfgdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")