re = /^(?:[^t]|t(?!his sequence))+$/m
str = 'ahkg\'ash fhsdh
dfh sdh dfh sdh dhfd hdf hdfh dtfh fdh
this sequence dg
gdsdfgdfgdfgdsfgdf
asd this sequence dg
gdsdfgdfgdfgdsfgdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end