import Foundation
let pattern = #"^(?:[^t]|t(?!his sequence))+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ahkg'ash fhsdh
dfh sdh dfh sdh dhfd hdf hdfh dtfh fdh
this sequence dg
gdsdfgdfgdfgdsfgdf
asd this sequence dg
gdsdfgdfgdfgdsfgdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)