$re = '/^(?:[^t]|t(?!his sequence))+$/m';
$str = 'ahkg\'ash fhsdh
dfh sdh dfh sdh dhfd hdf hdfh dtfh fdh
this sequence dg
gdsdfgdfgdfgdsfgdf
asd this sequence dg
gdsdfgdfgdfgdsfgdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);