import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^t]|t(?!his sequence))+$";
final String string = "ahkg'ash fhsdh\n"
+ " dfh sdh dfh sdh dhfd hdf hdfh dtfh fdh\n"
+ "this sequence dg\n"
+ "gdsdfgdfgdfgdsfgdf\n"
+ "asd this sequence dg\n"
+ "gdsdfgdfgdfgdsfgdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}