using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^t]|t(?!his sequence))+$";
string input = @"ahkg'ash fhsdh
dfh sdh dfh sdh dhfd hdf hdfh dtfh fdh
this sequence dg
gdsdfgdfgdfgdsfgdf
asd this sequence dg
gdsdfgdfgdfgdsfgdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}