#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/(?:www\.)?youtube\.com\b"
Local $sString = "https://www.youtube.com/watch?v=AAAAAAAAAAA" & @CRLF & _
"https://www.youtube.comm/watch?v=AAAAAAAAAA" & @CRLF & _
"https://youtube.com/watch?v=AAAAAAAAAAA" & @CRLF & _
"https://youtube.comm/watch?v=AAAAAAAAAAA" & @CRLF & _
"" & @CRLF & _
"youtube.com/watch?v=AAAAAAAAAAA" & @CRLF & _
"www.youtube.com/watch?v=AAAAAAAAAAA" & @CRLF & _
"https://example.com/redirect?url=https://www.youtube.com/watch?v=AAAAAAAAAAA" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")