import re
regex = re.compile(r"^https:\/\/(?:www\.)?youtube\.com\b", flags=re.MULTILINE)
test_str = ("https://www.youtube.com/watch?v=AAAAAAAAAAA\n"
"https://www.youtube.comm/watch?v=AAAAAAAAAA\n"
"https://youtube.com/watch?v=AAAAAAAAAAA\n"
"https://youtube.comm/watch?v=AAAAAAAAAAA\n\n"
"youtube.com/watch?v=AAAAAAAAAAA\n"
"www.youtube.com/watch?v=AAAAAAAAAAA\n"
"https://example.com/redirect?url=https://www.youtube.com/watch?v=AAAAAAAAAAA\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")