import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/(?:www\\.)?youtube\\.com\\b";
final String string = "https://www.youtube.com/watch?v=AAAAAAAAAAA\n"
+ "https://www.youtube.comm/watch?v=AAAAAAAAAA\n"
+ "https://youtube.com/watch?v=AAAAAAAAAAA\n"
+ "https://youtube.comm/watch?v=AAAAAAAAAAA\n\n"
+ "youtube.com/watch?v=AAAAAAAAAAA\n"
+ "www.youtube.com/watch?v=AAAAAAAAAAA\n"
+ "https://example.com/redirect?url=https://www.youtube.com/watch?v=AAAAAAAAAAA\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}