package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https:\/\/(?:www\.)?youtube\.com\b`)
var str = `https://www.youtube.com/watch?v=AAAAAAAAAAA
https://www.youtube.comm/watch?v=AAAAAAAAAA
https://youtube.com/watch?v=AAAAAAAAAAA
https://youtube.comm/watch?v=AAAAAAAAAAA
youtube.com/watch?v=AAAAAAAAAAA
www.youtube.com/watch?v=AAAAAAAAAAA
https://example.com/redirect?url=https://www.youtube.com/watch?v=AAAAAAAAAAA
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}