$re = '/(?:\[[^][]*]|\([^()]*\)|{[^{}]*})(*SKIP)(*F)|./m';
$str = 'Hello [123] {45} world (67)
Hello There (8) [9] {0}
(this]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;