using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<component>^\w+ +(?<head>.*)\n(?<body>(?:[\s\S](?!\n\w))*))";
string input = @"on join:
set the player's gamemode to spectator
join_player(player)
command /join [<player>]:
trigger:
if arg-1 is not set:
join_player(player)
else:
player has permission ""op""
join_player(arg-1)
function reset_arena():
set all blocks within {loc1} and {loc2} to snow block";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}