re = /(?<component>^\w+ +(?<head>.*)\n(?<body>(?:[\s\S](?!\n\w))*))/m
str = 'on join:
set the player\'s gamemode to spectator
join_player(player)
command /join [<player>]:
trigger:
if arg-1 is not set:
join_player(player)
else:
player has permission "op"
join_player(arg-1)
function reset_arena():
set all blocks within {loc1} and {loc2} to snow block'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end