$re = '/(?<component>^\w+ +(?<head>.*)\n(?<body>(?:[\s\S](?!\n\w))*))/m';
$str = 'on join:
set the player\'s gamemode to spectator
join_player(player)
command /join [<player>]:
trigger:
if arg-1 is not set:
join_player(player)
else:
player has permission "op"
join_player(arg-1)
function reset_arena():
set all blocks within {loc1} and {loc2} to snow block';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);