import re
regex = re.compile(r"(?<component>^\w+ +(?<head>.*)\n(?<body>(?:[\s\S](?!\n\w))*))", flags=re.MULTILINE)
test_str = ("on join:\n"
" set the player's gamemode to spectator\n"
" join_player(player)\n\n"
"command /join [<player>]:\n"
" trigger:\n"
" if arg-1 is not set:\n"
" join_player(player)\n"
" else:\n"
" player has permission \"op\"\n"
" join_player(arg-1)\n\n"
"function reset_arena():\n"
" set all blocks within {loc1} and {loc2} to snow block")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")