const regex = /(?<component>^\w+ +(?<head>.*)\n(?<body>(?:[\s\S](?!\n\w))*))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<component>^\\w+ +(?<head>.*)\\n(?<body>(?:[\\s\\S](?!\\n\\w))*))', 'gm')
const str = `on join:
set the player's gamemode to spectator
join_player(player)
command /join [<player>]:
trigger:
if arg-1 is not set:
join_player(player)
else:
player has permission "op"
join_player(arg-1)
function reset_arena():
set all blocks within {loc1} and {loc2} to snow block`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}