import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<component>^\\w+ +(?<head>.*)\\n(?<body>(?:[\\s\\S](?!\\n\\w))*))";
final String string = "on join:\n"
+ " set the player's gamemode to spectator\n"
+ " join_player(player)\n\n"
+ "command /join [<player>]:\n"
+ " trigger:\n"
+ " if arg-1 is not set:\n"
+ " join_player(player)\n"
+ " else:\n"
+ " player has permission \"op\"\n"
+ " join_player(arg-1)\n\n"
+ "function reset_arena():\n"
+ " set all blocks within {loc1} and {loc2} to snow block";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}