#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)<td><a href="bla">(.*?)</a>"
Local $sString = "<tr><td><a href="blu">blu</a></td><td>value</td></tr><tr><td><a href="bla">findme</a></td><td>value</td></tr><tr><td><a" & @CRLF & _
"href="ble">ble</a></td><td>value</td></tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")