re = /<td><a href="bla">(.*?)<\/a>/m
str = '<tr><td><a href="blu">blu</a></td><td>value</td></tr><tr><td><a href="bla">findme</a></td><td>value</td></tr><tr><td><a
href="ble">ble</a></td><td>value</td></tr>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end