import re
regex = re.compile(r"<td><a href=\"bla\">(.*?)</a>", flags=re.DOTALL | re.MULTILINE)
test_str = ("<tr><td><a href=\"blu\">blu</a></td><td>value</td></tr><tr><td><a href=\"bla\">findme</a></td><td>value</td></tr><tr><td><a\n"
"href=\"ble\">ble</a></td><td>value</td></tr>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")