$re = '%<td><a href="bla">(.*?)</a>%sm';
$str = '<tr><td><a href="blu">blu</a></td><td>value</td></tr><tr><td><a href="bla">findme</a></td><td>value</td></tr><tr><td><a
href="ble">ble</a></td><td>value</td></tr>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);