// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?sm)<td><a href="bla">(.*?)</a>"#).unwrap();
let string = "<tr><td><a href=\"blu\">blu</a></td><td>value</td></tr><tr><td><a href=\"bla\">findme</a></td><td>value</td></tr><tr><td><a
href=\"ble\">ble</a></td><td>value</td></tr>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}