import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td><a href=\"bla\">(.*?)</a>";
final String string = "<tr><td><a href=\"blu\">blu</a></td><td>value</td></tr><tr><td><a href=\"bla\">findme</a></td><td>value</td></tr><tr><td><a\n"
+ "href=\"ble\">ble</a></td><td>value</td></tr>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}