#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m),[a-zA-Z ]+,1"
Local $sString = "1351,Adanac St,North,2,2015" & @CRLF & _
"1375,Adanac St,North,1,2015" & @CRLF & _
"305,Alexander St,North,1,2012" & @CRLF & _
"320,Alexander St,South,2,2014" & @CRLF & _
"429,Alexander St,North,2,2015" & @CRLF & _
"475,Alexander St,North,2,2012" & @CRLF & _
"611,Alexander St,North,3,2015" & @CRLF & _
"200,Alexander St,North,2,2012"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")