// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m),[a-zA-Z ]+,1").unwrap();
let string = "1351,Adanac St,North,2,2015
1375,Adanac St,North,1,2015
305,Alexander St,North,1,2012
320,Alexander St,South,2,2014
429,Alexander St,North,2,2015
475,Alexander St,North,2,2012
611,Alexander St,North,3,2015
200,Alexander St,North,2,2012";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}