use strict;
my $str = '1351,Adanac St,North,2,2015
1375,Adanac St,North,1,2015
305,Alexander St,North,1,2012
320,Alexander St,South,2,2014
429,Alexander St,North,2,2015
475,Alexander St,North,2,2012
611,Alexander St,North,3,2015
200,Alexander St,North,2,2012';
my $regex = qr/,[a-zA-Z ]+,1/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}