# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r",[a-zA-Z ]+,1"
test_str = ("1351,Adanac St,North,2,2015\n"
"1375,Adanac St,North,1,2015\n"
"305,Alexander St,North,1,2012\n"
"320,Alexander St,South,2,2014\n"
"429,Alexander St,North,2,2015\n"
"475,Alexander St,North,2,2012\n"
"611,Alexander St,North,3,2015\n"
"200,Alexander St,North,2,2012")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.