import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",[a-zA-Z ]+,1";
final String string = "1351,Adanac St,North,2,2015\n"
+ "1375,Adanac St,North,1,2015\n"
+ "305,Alexander St,North,1,2012\n"
+ "320,Alexander St,South,2,2014\n"
+ "429,Alexander St,North,2,2015\n"
+ "475,Alexander St,North,2,2012\n"
+ "611,Alexander St,North,3,2015\n"
+ "200,Alexander St,North,2,2012";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}