const regex = /^(?=[a-z][^_]*_?[^_]+$)\w{4,}$/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[a-z][^_]*_?[^_]+$)\\w{4,}$', 'img')
const str = `a88
hell_0
_und
u_nd
un_d
und_
u_n_
u__d
8_no
hell0_
helol_z
he_lo
it is made up of at least 4 characters
it can contain only word character, number, and underscore (max. one time)
it should start with a word character and it cannot end with an underscore.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}