import re
regex = re.compile(r"^(?=[a-z][^_]*_?[^_]+$)\w{4,}$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("a88\n"
"hell_0\n"
"_und\n"
"u_nd\n"
"un_d\n"
"und_\n"
"u_n_\n"
"u__d\n"
"8_no\n"
"hell0_\n"
"helol_z\n"
"he_lo\n\n\n"
"it is made up of at least 4 characters\n"
"it can contain only word character, number, and underscore (max. one time)\n"
"it should start with a word character and it cannot end with an underscore.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")