import Foundation
let pattern = #"^(?=[a-z][^_]*_?[^_]+$)\w{4,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
a88
hell_0
_und
u_nd
un_d
und_
u_n_
u__d
8_no
hell0_
helol_z
he_lo
it is made up of at least 4 characters
it can contain only word character, number, and underscore (max. one time)
it should start with a word character and it cannot end with an underscore.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)