re = /^(?=[a-z][^_]*_?[^_]+$)\w{4,}$/im
str = 'a88
hell_0
_und
u_nd
un_d
und_
u_n_
u__d
8_no
hell0_
helol_z
he_lo
it is made up of at least 4 characters
it can contain only word character, number, and underscore (max. one time)
it should start with a word character and it cannot end with an underscore.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end