# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)(?!\S*flowers\.com\.au)(\w+(?:\.[^\s,.#]+)+)/<a href="$1">$1<\/a>/gm;t' <<< "this is example.com.au and this is exampleflowers.com.au and of course another anotherexample.com.au/terms.html, url. Oh no exampleflowers.com.au is in this sentence again."