$re = '/(?<!\S)(?!\S*flowers\.com\.au)(\w+(?:\.[^\s,.#]+)+)/m';
$str = 'this is example.com.au and this is exampleflowers.com.au and of course another anotherexample.com.au/terms.html, url. Oh no exampleflowers.com.au is in this sentence again.';
$subst = "<a href=\"$1\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;