import re
regex = re.compile(r"(?<!\S)(?!\S*flowers\.com\.au)(\w+(?:\.[^\s,.#]+)+)", flags=re.MULTILINE)
test_str = "this is example.com.au and this is exampleflowers.com.au and of course another anotherexample.com.au/terms.html, url. Oh no exampleflowers.com.au is in this sentence again."
subst = "<a href=\"$1\">$1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)