re = /(?<!\S)(?!\S*flowers\.com\.au)(\w+(?:\.[^\s,.#]+)+)/m
str = 'this is example.com.au and this is exampleflowers.com.au and of course another anotherexample.com.au/terms.html, url. Oh no exampleflowers.com.au is in this sentence again.'
subst = '<a href="$1">$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result