use strict;
my $str = 'this is example.com.au and this is exampleflowers.com.au and of course another anotherexample.com.au/terms.html, url. Oh no exampleflowers.com.au is in this sentence again.';
my $regex = qr/(?<!\S)(?!\S*flowers\.com\.au)(\w+(?:\.[^\s,.#]+)+)/mp;
my $subst = '<a href="$1">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";