#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[1-9]{1,}[0-9]{9,11}"
Local $sString = "Пример: 100000-0000" & @CRLF & _
"Пример: 10000000-0000" & @CRLF & _
"Пример: 190000000000 " & @CRLF & _
"" & @CRLF & _
"Пример: 550000-0000" & @CRLF & _
"Пример: 5500000000" & @CRLF & _
"Пример, любые 10 цифр (первая цифра больше 0): 1000000000 " & @CRLF & _
"Пример, любые 12 цифр (первая цифра больше 0): 100000000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")