use strict;
my $str = 'Пример: 100000-0000
Пример: 10000000-0000
Пример: 190000000000
Пример: 550000-0000
Пример: 5500000000
Пример, любые 10 цифр (первая цифра больше 0): 1000000000
Пример, любые 12 цифр (первая цифра больше 0): 100000000000';
my $regex = qr/[1-9]{1,}[0-9]{9,11}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}