# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[1-9]{1,}[0-9]{9,11}"
test_str = ("Пример: 100000-0000\n"
"Пример: 10000000-0000\n"
"Пример: 190000000000 \n\n"
"Пример: 550000-0000\n"
"Пример: 5500000000\n"
"Пример, любые 10 цифр (первая цифра больше 0): 1000000000 \n"
"Пример, любые 12 цифр (первая цифра больше 0): 100000000000")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.