package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[1-9]{1,}[0-9]{9,11}`)
var str = `Пример: 100000-0000
Пример: 10000000-0000
Пример: 190000000000
Пример: 550000-0000
Пример: 5500000000
Пример, любые 10 цифр (первая цифра больше 0): 1000000000
Пример, любые 12 цифр (первая цифра больше 0): 100000000000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}