import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[1-9]{1,}[0-9]{9,11}";
final String string = "Пример: 100000-0000\n"
+ "Пример: 10000000-0000\n"
+ "Пример: 190000000000 \n\n"
+ "Пример: 550000-0000\n"
+ "Пример: 5500000000\n"
+ "Пример, любые 10 цифр (первая цифра больше 0): 1000000000 \n"
+ "Пример, любые 12 цифр (первая цифра больше 0): 100000000000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}