re = /[1-9]{1,}[0-9]{9,11}/
str = 'Пример: 100000-0000
Пример: 10000000-0000
Пример: 190000000000
Пример: 550000-0000
Пример: 5500000000
Пример, любые 10 цифр (первая цифра больше 0): 1000000000
Пример, любы е 12 цифр (первая цифра больше 0): 100000000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end