package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\s+(?:misses|makes)\b.*$`)
var str = `D. Rodman makes 2-pt layup (assist by L. Longley)
M. Jordan misses 2-pt jump shot from 15 ft`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}