$re = '/^(.*?)\s+(?:misses|makes)\b.*$/m';
$str = 'D. Rodman makes 2-pt layup (assist by L. Longley)
M. Jordan misses 2-pt jump shot from 15 ft';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);