import re
regex = re.compile(r"^(.*?)\s+(?:misses|makes)\b.*$", flags=re.MULTILINE)
test_str = ("D. Rodman makes 2-pt layup (assist by L. Longley)\n"
"M. Jordan misses 2-pt jump shot from 15 ft")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")