re = /^(.*?)\s+(?:misses|makes)\b.*$/m
str = 'D. Rodman makes 2-pt layup (assist by L. Longley)
M. Jordan misses 2-pt jump shot from 15 ft'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end